My newly built PC stopped recognizing my GPU after about a month


New member
I built a new PC recently, and everything went well for about 3 weeks. Games started crashing seemingly completely at random (not during particularly graphics intensive moments or anything), then finally one day while I was playing BG3 my whole computer crashed and fully shut down. When I tried to boot it back up, I got a black screen and the VGA error LED was lit up on the motherboard.

I switched my HDMI cable over to the slot for my CPU's onboard graphics, and was able to boot normally. Once I got into windows, I checked device manager and saw that windows was no longer recognizing my GPU at all - the only display device listed was the integrated graphics.

These are my PC parts:

ASUS ROG STRIX B650E-F Gaming Wifi (motherboard)
AMD Ryzen 9 7900x
G.Skill Ripjaws S5 Series DDR5 RAM 16GB (x2) 6400MT/s
Corsair RM750x 750 watt fully modular PSU
EVGA Nvidia GeForce RTX 2060

I tried cleaning the PCIe slot, and re-seating my GPU. I even tried a couple different old (but still functional) GPUs that I have laying around. Those were also not recognized, though I could tell they were getting power from the motherboard because the fans would still come on. I have a tiny GPU that doesn't use PSU power, and its fans came on but still didn't show up in device manager or the UEFI. In this way, I feel like I can rule out my (brand new) power supply being bad (since the GPU which doesn't require PSU power also didn't work).

I also have tried my GPU in a friend's PC, and it works completely normally, so the GPU is not faulty.

The HDMI cable I'm using works perfectly for my laptop, and just to cover my bases I tried a different cable with my GPU and that also didn't work.

I couldn't reinstall the Nvidia drivers because the machine doesn't think there's a graphics card installed at all. I even backed up my data and did a fresh reinstall of windows, but it still wouldn't recognize the GPU.

I updated my UEFI/BIOS to the most recent update, I searched through the UEFI for possible settings to help, and never had any success. I tried changing PCIe bifurcation settings, I tried manually setting PCIe speed to Gen 3, and several other shots in the dark to no avail. It had to be the motherboard's PCIe slot itself that was broken, right!?

I sent the motherboard back to ASUS for repair, and they replaced it, but with the replacement motherboard I'm having the exact same issue.

What else is left to check? Could it possibly be that my CPU's PCIe controller lanes are shot somehow, even though the computer seems to boot and run okay? I did forget to mention, when I'm running on integrated graphics I get strange graphical errors pretty frequently. Like occasionally black and green rectangles suddenly appear all over the screen, and they stay there and distort and change when I drag windows around or move the mouse.

Edit: Small update, I've been doing even MORE research and I noticed that the SPECIFIC version of the RAM I'm using is not officially certified as "supported" by my motherboard. The official list contains 6000, 7000 and even 8000 "speed" RAM (from G.Skill, even) but I'm using 6400 which is not listed. Nothing I've researched leads me to believe this is the issue, but can anyone confirm or deny that?
Last edited: